Issues accessing Self-Service
Incident Report for Cintra
Resolved
This incident has been resolved.
Posted Nov 24, 2023 - 09:41 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 22, 2023 - 10:09 GMT
Investigating
We are currently investigating issues regarding accessing Cintra Self-Service.
Posted Nov 22, 2023 - 09:14 GMT
This incident affected: Cintra IQ (Cintra IQ - Self Service).