Issue connecting to CintraIQ payroll

Incident Report for Cintra

Resolved

This incident has now been resolved. Please refresh your browser window and log in again to connect.
Posted Jun 09, 2025 - 11:21 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 09, 2025 - 08:56 BST

Investigating

We are currently experiencing an issue with connection to CintraIQ payroll. This is under investigation.
Posted Jun 09, 2025 - 08:33 BST
This incident affected: Cintra IQ (Cintra IQ).