Issues logging into Cintra IQ
Incident Report for Cintra
Resolved
We have implemented a fix to Cintra IQ to resolve client login issues.

This fix has been applied to all client servers and we are continuing to monitor access.

Thank you for your patience.
Posted Mar 15, 2024 - 17:16 GMT
Investigating
We are currently aware of an issue affecting access to Cintra IQ, we are currently investigating the cause.

Further updates will follow once the cause is identified.
Posted Mar 15, 2024 - 16:40 GMT
This incident affected: Cintra IQ (Cintra IQ - VPN Free).