Issue with Self-Service
Incident Report for Cintra
Resolved
This issue is now resolved.
Posted Jun 09, 2023 - 12:35 BST
Identified
We have identified the cause of the Incident and are looking to rectify now; we will provide a further update within 30 minutes.
Posted Jun 09, 2023 - 12:24 BST
Investigating
We are actively investigating an issue with Self-Service.
Posted Jun 09, 2023 - 12:14 BST
This incident affected: Cintra IQ (Cintra IQ - Self Service).