Payslip Printing and Self-Service Access Issues

Incident Report for Cintra

Resolved

This incident has now been resolved
Posted Mar 25, 2026 - 11:39 GMT

Identified

We are currently experiencing issues affecting payslip printing and Self-Service this morning. Our engineers have identified the issues and are actively working on a fix. We are treating this as a priority and will provide further updates as soon as possible.
Posted Mar 25, 2026 - 09:13 GMT
This incident affected: Cintra IQ (Cintra IQ - Self Service, Cintra IQ).