Cintra Cloud is experiencing issues
Incident Report for Cintra
Resolved
Issue resolved. We have identified that this issue is impacting no customer production organisations.
Posted May 25, 2023 - 08:39 BST
Investigating
We have identified an issue with Cintra Cloud after users log in. We are currently investigating and will provide an update in 15 minutes
Posted May 25, 2023 - 08:28 BST
This incident affected: Cintra Cloud (Cintra Cloud - Payroll, Cintra Cloud - Employee Hub).